Support Centre

I am trying to install a DeLorme inReach firmware update but it is not working. What could the problem be?

Last Updated: Jun 17, 2013 03:53PM IST
DeLorme inReach firmware updates require version 1.4 or later of the DeLorme Send to GPS Plugin. If you do not have version 1.4 or later then go to http://www.delorme.com/plugins/gpsplugin.aspx to download and install the DeLorme Send to GPS Plugin.

Contact Us

4411a3d4a118ad93098a35965e0d4a60@globaltelesat.desk-mail.com
http://assets3.desk.com/
false
globaltelesatuk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete